import Foundation
let pattern = #"^[a-zA-Z0-9-]+:[ a-zA-Z0-9()'\"-_.]+;\s?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
border-bottom-color: coral;
column-rule: 4px double #ff00ff;
grid-area: 2 / 1 / span 2 (00)/ span 3;
list-style: square inside url("sqpurple.gif");
object-position: 5px 10%;
border: 5px solid red;
background-color: hsla(89, 43%, 51%, 0.3);
font-variant-caps: all-small-caps;
background-image: url('img_tree.gif'), url("paper.gif");
width: calc(var(--variable-width) + 20px);
width: calc(2em *+- 5);
grid-template-columns: 1fr fit-content(250px);
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)