const regex = new RegExp('^[a-zA-Z0-9-]+:[ a-zA-Z0-9()\\'\\"-_.]+;\\s?', 'gmi')
const str = `border-bottom-color: coral;
column-rule: 4px double #ff00ff;
grid-area: 2 / 1 / span 2 (00)/ span 3;
list-style: square inside url("sqpurple.gif");
object-position: 5px 10%;
border: 5px solid red;
background-color: hsla(89, 43%, 51%, 0.3);
font-variant-caps: all-small-caps;
background-image: url('img_tree.gif'), url("paper.gif");
width: calc(var(--variable-width) + 20px);
width: calc(2em *+- 5);
grid-template-columns: 1fr fit-content(250px);`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}