using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9-]+:[ a-zA-Z0-9()'\""-_.]+;\s?";
string input = @"border-bottom-color: coral;
column-rule: 4px double #ff00ff;
grid-area: 2 / 1 / span 2 (00)/ span 3;
list-style: square inside url(""sqpurple.gif"");
object-position: 5px 10%;
border: 5px solid red;
background-color: hsla(89, 43%, 51%, 0.3);
font-variant-caps: all-small-caps;
background-image: url('img_tree.gif'), url(""paper.gif"");
width: calc(var(--variable-width) + 20px);
width: calc(2em *+- 5);
grid-template-columns: 1fr fit-content(250px);";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}