import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9-]+:[ a-zA-Z0-9()'\\\"-_.]+;\\s?";
final String string = "border-bottom-color: coral;\n"
+ "column-rule: 4px double #ff00ff;\n"
+ "grid-area: 2 / 1 / span 2 (00)/ span 3;\n"
+ "list-style: square inside url(\"sqpurple.gif\");\n"
+ "object-position: 5px 10%;\n"
+ "border: 5px solid red;\n"
+ "background-color: hsla(89, 43%, 51%, 0.3);\n"
+ "font-variant-caps: all-small-caps;\n"
+ "background-image: url('img_tree.gif'), url(\"paper.gif\");\n"
+ "width: calc(var(--variable-width) + 20px);\n"
+ "width: calc(2em *+- 5);\n"
+ "grid-template-columns: 1fr fit-content(250px);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}