$re = '/^[a-zA-Z0-9-]+:[ a-zA-Z0-9()\'\"-_.]+;\s?/mi';
$str = 'border-bottom-color: coral;
column-rule: 4px double #ff00ff;
grid-area: 2 / 1 / span 2 (00)/ span 3;
list-style: square inside url("sqpurple.gif");
object-position: 5px 10%;
border: 5px solid red;
background-color: hsla(89, 43%, 51%, 0.3);
font-variant-caps: all-small-caps;
background-image: url(\'img_tree.gif\'), url("paper.gif");
width: calc(var(--variable-width) + 20px);
width: calc(2em *+- 5);
grid-template-columns: 1fr fit-content(250px);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);