// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\n").unwrap();
let string = "Top
Arts
Business
Comedy
Education
Games_Hobbies
Government_Organizations
Health
Education
Kids_Family
Music
News_Politics
Religion_Spirituality
Science_Medicine
Society_Culture
Sports_Recreation
Technology
TV_Film
";
let substitution = "\"$1\", ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}