const regex = /0|1|2|3|4|5|6|7|8|9/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0|1|2|3|4|5|6|7|8|9', 'gm')
const str = `1234
adsfad
adafd3334
asd fasdf12 34
شسيبشيسب
شيسبش سيبشسيب232323111111111111
123
شسيبشسيبشسيب
١١إحدى عشر
١١`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}