using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0|1|2|3|4|5|6|7|8|9";
string input = @"1234
adsfad
adafd3334
asd fasdf12 34
شسيبشيسب
شيسبش سيبشسيب232323111111111111
123
شسيبشسيبشسيب
١١إحدى عشر
١١";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}