import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0|1|2|3|4|5|6|7|8|9";
final String string = "1234\n"
+ "adsfad\n"
+ "adafd3334\n"
+ "asd fasdf12 34\n"
+ "شسيبشيسب\n"
+ "شيسبش سيبشسيب232323111111111111\n"
+ "123\n\n"
+ "شسيبشسيبشسيب\n"
+ "١١إحدى عشر\n"
+ "١١";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}