#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)0|1|2|3|4|5|6|7|8|9"
Local $sString = "1234" & @CRLF & _
"adsfad" & @CRLF & _
"adafd3334" & @CRLF & _
"asd fasdf12 34" & @CRLF & _
"شسيبشيسب" & @CRLF & _
"شيسبش سيبشسيب232323111111111111" & @CRLF & _
"123" & @CRLF & _
"" & @CRLF & _
"شسيبشسيبشسيب" & @CRLF & _
"١١إحدى عشر" & @CRLF & _
"١١"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")