package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0|1|2|3|4|5|6|7|8|9`)
var str = `1234
adsfad
adafd3334
asd fasdf12 34
شسيبشيسب
شيسبش سيبشسيب232323111111111111
123
شسيبشسيبشسيب
١١إحدى عشر
١١`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}