// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:DCIM|img)(?:.*)(?:jp.?g|png)").unwrap();
let string = "/ext/DCIM/test/123.jpg
/ext/DCIM/test/123.png
/ext/img/test/123.jpg
/ext/img/test/123.jpeg
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}