re = /(?:DCIM|img)(?:.*)(?:jp.?g|png)/
str = '/ext/DCIM/test/123.jpg
/ext/DCIM/test/123.png
/ext/img/test/123.jpg
/ext/img/test/123.jpeg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end