import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:DCIM|img)(?:.*)(?:jp.?g|png)";
final String string = "/ext/DCIM/test/123.jpg\n"
+ "/ext/DCIM/test/123.png\n"
+ "/ext/img/test/123.jpg\n"
+ "/ext/img/test/123.jpeg\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}