package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:DCIM|img)(?:.*)(?:jp.?g|png)`)
var str = `/ext/DCIM/test/123.jpg
/ext/DCIM/test/123.png
/ext/img/test/123.jpg
/ext/img/test/123.jpeg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}