#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:DCIM|img)(?:.*)(?:jp.?g|png)"
Local $sString = "/ext/DCIM/test/123.jpg" & @CRLF & _
"/ext/DCIM/test/123.png" & @CRLF & _
"/ext/img/test/123.jpg" & @CRLF & _
"/ext/img/test/123.jpeg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")