import Foundation
let pattern = #"(const uint[138][26]?_t)(\s?\S+\s*) (\s*[0-9]*[xXa-fA-F0-9]*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"const uint8_t T_SYN_3 23"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2 = \3;"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}