re = /(const uint[138][26]?_t)(\s?\S+\s*) (\s*[0-9]*[xXa-fA-F0-9]*)$/
str = 'const uint8_t T_SYN_3 23'
subst = '\\1\\2 = \\3;'
result = str.sub(re, subst)
# Print the result of the substitution
puts result