using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(const uint[138][26]?_t)(\s?\S+\s*) (\s*[0-9]*[xXa-fA-F0-9]*)$";
string substitution = @"\1\2 = \3;";
string input = @"const uint8_t T_SYN_3 23";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}