# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(const uint[138][26]?_t)(\s?\S+\s*) (\s*[0-9]*[xXa-fA-F0-9]*)$"
test_str = "const uint8_t T_SYN_3 23"
subst = "\\1\\2 = \\3;"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.