const regex = /(const uint[138][26]?_t)(\s?\S+\s*) (\s*[0-9]*[xXa-fA-F0-9]*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(const uint[138][26]?_t)(\\s?\\S+\\s*) (\\s*[0-9]*[xXa-fA-F0-9]*)$', '')
const str = `const uint8_t T_SYN_3 23`;
const subst = `\1\2 = \3;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);