# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-zA-Z0-9/<]){9}[0-9]([A-Za-z]){3}([0-9]){6}([0-9])([MmFf\<])([0-9])([0-9]){6}([a-zA-Z0-9/<]){14}([0-9]){2}"
test_str = ("#Fictional MRT\n"
"L898902C<3UTO6908061F9406236ZE184226B<<<<<14\n"
"#Sample USA\n"
"3400072370USA6707046F1608078910000193<113538\n"
"#Sample JPN\n"
"XS12345673JPN7902206F1101018<<<<<<<<<<<<<<00\n"
"#Sample UK\n"
"4580059179GBR7310216M1602135<<<<<<<<<<<<<<06\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.