using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z0-9/<]){9}[0-9]([A-Za-z]){3}([0-9]){6}([0-9])([MmFf\<])([0-9])([0-9]){6}([a-zA-Z0-9/<]){14}([0-9]){2}";
string input = @"#Fictional MRT
L898902C<3UTO6908061F9406236ZE184226B<<<<<14
#Sample USA
3400072370USA6707046F1608078910000193<113538
#Sample JPN
XS12345673JPN7902206F1101018<<<<<<<<<<<<<<00
#Sample UK
4580059179GBR7310216M1602135<<<<<<<<<<<<<<06
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}