use strict;
my $str = '#Fictional MRT
L898902C<3UTO6908061F9406236ZE184226B<<<<<14
#Sample USA
3400072370USA6707046F1608078910000193<113538
#Sample JPN
XS12345673JPN7902206F1101018<<<<<<<<<<<<<<00
#Sample UK
4580059179GBR7310216M1602135<<<<<<<<<<<<<<06
';
my $regex = qr/([a-zA-Z0-9/<]){9}[0-9]([A-Za-z]){3}([0-9]){6}([0-9])([MmFf\<])([0-9])([0-9]){6}([a-zA-Z0-9/<]){14}([0-9]){2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}