import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9/<]){9}[0-9]([A-Za-z]){3}([0-9]){6}([0-9])([MmFf\\<])([0-9])([0-9]){6}([a-zA-Z0-9/<]){14}([0-9]){2}";
final String string = "#Fictional MRT\n"
+ "L898902C<3UTO6908061F9406236ZE184226B<<<<<14\n"
+ "#Sample USA\n"
+ "3400072370USA6707046F1608078910000193<113538\n"
+ "#Sample JPN\n"
+ "XS12345673JPN7902206F1101018<<<<<<<<<<<<<<00\n"
+ "#Sample UK\n"
+ "4580059179GBR7310216M1602135<<<<<<<<<<<<<<06\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}