// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|\s)(?'arg1'[a-z]+)=(?P=arg1)").unwrap();
let string = "abc=abc
abcd=abc
qwe=ewq
qwe=qwe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}