re = /(?:^|\s)(?'arg1'[a-z]+)=(?P=arg1)/
str = 'abc=abc
abcd=abc
qwe=ewq
qwe=qwe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end