using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\s)(?'arg1'[a-z]+)=(?P=arg1)";
string input = @"abc=abc
abcd=abc
qwe=ewq
qwe=qwe";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}