$re = '/(?:^|\s)(?\'arg1\'[a-z]+)=(?P=arg1)/';
$str = 'abc=abc
abcd=abc
qwe=ewq
qwe=qwe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);