package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|\s)(?'arg1'[a-z]+)=(?P=arg1)`)
var str = `abc=abc
abcd=abc
qwe=ewq
qwe=qwe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}