import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?P<LongDate>(?P<Day>\d+)\.?[\s ]+(?P<Month>januára|januáru|februára|februáru|marec|marca|apríla|aprílu|májom|mája|máju|máj|júnu|júna|júlu|júla|augusta|augustu|septembra|septembru|októbra|októbru|novembra|novembru|decembra|decembru)[\s ]+(?P<Year>\d{4}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
z 11. júla 2006,
z 19. septembra 1985,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)