# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<LongDate>(?P<Day>\d+)\.?[\s ]+(?P<Month>januára|januáru|februára|februáru|marec|marca|apríla|aprílu|májom|mája|máju|máj|júnu|júna|júlu|júla|augusta|augustu|septembra|septembru|októbra|októbru|novembra|novembru|decembra|decembru)[\s ]+(?P<Year>\d{4}))"
test_str = ("z 11. júla 2006,\n"
"z 19. septembra 1985,\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.