use strict;
my $str = 'z 11. júla 2006,
z 19. septembra 1985,
';
my $regex = qr/(?P<LongDate>(?P<Day>\d+)\.?[\s ]+(?P<Month>januára|januáru|februára|februáru|marec|marca|apríla|aprílu|májom|mája|máju|máj|júnu|júna|júlu|júla|augusta|augustu|septembra|septembru|októbra|októbru|novembra|novembru|decembra|decembru)[\s ]+(?P<Year>\d{4}))/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}