import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<LongDate>(?P<Day>\\d+)\\.?[\\s ]+(?P<Month>januára|januáru|februára|februáru|marec|marca|apríla|aprílu|májom|mája|máju|máj|júnu|júna|júlu|júla|augusta|augustu|septembra|septembru|októbra|októbru|novembra|novembru|decembra|decembru)[\\s ]+(?P<Year>\\d{4}))";
final String string = "z 11. júla 2006,\n"
+ "z 19. septembra 1985,\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}