using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<LongDate>(?P<Day>\d+)\.?[\s ]+(?P<Month>januára|januáru|februára|februáru|marec|marca|apríla|aprílu|májom|mája|máju|máj|júnu|júna|júlu|júla|augusta|augustu|septembra|septembru|októbra|októbru|novembra|novembru|decembra|decembru)[\s ]+(?P<Year>\d{4}))";
string input = @"z 11. júla 2006,
z 19. septembra 1985,
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}