// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)201\d\.(?<Month>\w*)\d\d\-").unwrap();
let string = "<h2 class=\"align-center title-green\">A 2016.
június 15-i, 356. sorsolás
eredménye</h2>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}