using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"201\d\.(?<Month>\w*)\d\d\-";
string input = @"<h2 class=""align-center title-green"">A 2016.
június 15-i, 356. sorsolás
eredménye</h2>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}