$re = '/201\d\.(?<Month>\w*)\d\d\-/ms';
$str = '<h2 class="align-center title-green">A 2016.
június 15-i, 356. sorsolás
eredménye</h2>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);