use strict;
my $str = '<h2 class="align-center title-green">A 2016.
június 15-i, 356. sorsolás
eredménye</h2>';
my $regex = qr/201\d\.(?<Month>\w*)\d\d\-/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}