import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "201\\d\\.(?<Month>\\w*)\\d\\d\\-";
final String string = "<h2 class=\"align-center title-green\">A 2016.\n"
+ " június 15-i, 356. sorsolás\n"
+ "eredménye</h2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}