re = /(?'indlvl'\s+)
if\(asd\)\n\s+\{\n\s+
(?:[\w\W]*)
\n\k'indlvl'\}/mx
str = '{
if(asd)
{
asd q="fg"
{
q
}
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end