package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?'indlvl'\s+)
if\(asd\)\n\s+\{\n\s+
(?:[\w\W]*)
\n\k'indlvl'\}`)
var str = `{
if(asd)
{
asd q="fg"
{
q
}
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}