#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?'indlvl'\s+)" & @CRLF & _
"if\(asd\)\n\s+\{\n\s+" & @CRLF & _
"(?:[\w\W]*)" & @CRLF & _
"\n\k'indlvl'\}"
Local $sString = "{" & @CRLF & _
" if(asd)" & @CRLF & _
" {" & @CRLF & _
" asd q="fg"" & @CRLF & _
" {" & @CRLF & _
" q" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")