import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'indlvl'\\s+)\n"
+ "if\\(asd\\)\\n\\s+\\{\\n\\s+\n"
+ "(?:[\\w\\W]*)\n"
+ "\\n\\k'indlvl'\\}";
final String string = "{\n"
+ " if(asd)\n"
+ " {\n"
+ " asd q=\"fg\"\n"
+ " {\n"
+ " q\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}