$re = '/(?\'indlvl\'\s+)
if\(asd\)\n\s+\{\n\s+
(?:[\w\W]*)
\n\k\'indlvl\'\}/mx';
$str = '{
if(asd)
{
asd q="fg"
{
q
}
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);