const regex = /@media([^{]+)\{([\s\S]+?})\s*}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@media([^{]+)\\{([\\s\\S]+?})\\s*}', 'g')
const str = `@media (max-width: 868px) {
aside .size-toggle {
display: none;
}
}
@media (max-width: 767px) {
#wrapper.sidebar-display aside {
left: 0;
transition: all 0.5s ease;
-webkit-transition: all 0.5s ease;
-moz-transition: all 0.5s ease;
-ms-transition: all 0.5s ease;
-o-transition: all 0.5s ease;
}
#wrapper.sidebar-display #top-nav {
left: 0;
right: -194px;
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}