import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@media([^\\{]+)\\{([\\s\\S]+?\\})\\s*\\}";
final String string = "@media (max-width: 868px) {\n"
+ " aside .size-toggle {\n"
+ " display: none;\n"
+ " }\n"
+ "}\n\n"
+ "@media (max-width: 767px) {\n"
+ " #wrapper.sidebar-display aside {\n"
+ " left: 0;\n"
+ " transition: all 0.5s ease;\n"
+ " -webkit-transition: all 0.5s ease;\n"
+ " -moz-transition: all 0.5s ease;\n"
+ " -ms-transition: all 0.5s ease;\n"
+ " -o-transition: all 0.5s ease;\n"
+ " }\n"
+ " #wrapper.sidebar-display #top-nav {\n"
+ " left: 0;\n"
+ " right: -194px;\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}