package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@media([^{]+)\{([\s\S]+?})\s*}`)
var str = `@media (max-width: 868px) {
aside .size-toggle {
display: none;
}
}
@media (max-width: 767px) {
#wrapper.sidebar-display aside {
left: 0;
transition: all 0.5s ease;
-webkit-transition: all 0.5s ease;
-moz-transition: all 0.5s ease;
-ms-transition: all 0.5s ease;
-o-transition: all 0.5s ease;
}
#wrapper.sidebar-display #top-nav {
left: 0;
right: -194px;
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}