using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@media([^{]+)\{([\s\S]+?})\s*}";
string input = @"@media (max-width: 868px) {
aside .size-toggle {
display: none;
}
}
@media (max-width: 767px) {
#wrapper.sidebar-display aside {
left: 0;
transition: all 0.5s ease;
-webkit-transition: all 0.5s ease;
-moz-transition: all 0.5s ease;
-ms-transition: all 0.5s ease;
-o-transition: all 0.5s ease;
}
#wrapper.sidebar-display #top-nav {
left: 0;
right: -194px;
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}