#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@media([^{]+)\{([\s\S]+?})\s*}"
Local $sString = "@media (max-width: 868px) {" & @CRLF & _
" aside .size-toggle {" & @CRLF & _
" display: none;" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@media (max-width: 767px) {" & @CRLF & _
" #wrapper.sidebar-display aside {" & @CRLF & _
" left: 0;" & @CRLF & _
" transition: all 0.5s ease;" & @CRLF & _
" -webkit-transition: all 0.5s ease;" & @CRLF & _
" -moz-transition: all 0.5s ease;" & @CRLF & _
" -ms-transition: all 0.5s ease;" & @CRLF & _
" -o-transition: all 0.5s ease;" & @CRLF & _
" }" & @CRLF & _
" #wrapper.sidebar-display #top-nav {" & @CRLF & _
" left: 0;" & @CRLF & _
" right: -194px;" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")